Back to overview
Resolved

Current-RMS API is currently degraded.

May 5, 2026 at 3:30pm UTC
Affected services
Warehouse Buddy API Proxy

Resolved
May 5, 2026 at 6:30pm UTC

Current-RMS have confirmed there services have returned back to normal and we are seeing performance improvements.

Created
May 5, 2026 at 3:30pm UTC

Current-RMS's services are currently degraded and running slower than usual, which may result in our Warehouse Buddy backend services running slower than usual.