Back to overview
Resolved
Warehouse Buddy upstream providers are preforming maintenance
May 10, 2026 at 4:00am UTC
–
May 10, 2026 at 6:00am UTC
Affected services
Warehouse Buddy API Proxy
Resolved
May 10, 2026 at 6:00am UTC
Maintenance ended
Affected services
Created
May 10, 2026 at 4:00am UTC
Current-RMS will be preforming maintenance across their Dashboard, API and Email delivery services, this may result in degraded performance within Warehouse Buddy or API responses failing.
You can keep updated on the maintenance here: https://status.current-rms.com/
Affected services